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Objective: 

in this TP, we will describe the different tools available in QGIS and OTB, and we will give examples 

of the manipulation of satellite images (Sentinel-2) 

In this TP, we will address the following points: 

➢ An introduction to QGIS 

➢ Images and metadata 

➢ Creating a stacked image « stack » using multiple bands 

➢ Managing projections and clipping  

➢ Superimposing two images 

➢ Calculating NDVI 

➢ Classifying the Land Cover by a multiband threshold  

Prerequisite TP: 

1. Installation of QGIS (3.20) 

2. Installation of OTB (OrfeoToolbox) 

  



0. Images and Metadata : 

Objective: Rea and understand the metadata of satellite images. 

Steps Manipulation 

0.1. Open QGIS 

program 
➢ After installing « QGIS », QGIS becomes available for use on your computer. You can now launch  

the QGIS program by double clicking the « QGIS » icon, now you will see the following interface 

 

➢ The interface is separated into sections: 

o 1. The menu bar 

o 2. Tools bar 

o 3. TOC (Table of Content) 

o 4. Map display space 

o 5. Status bar 

0.2. Add an 

image to QGIS 
➢ In the menu, click on « Layer » ➔ « Add layer» ➔ « Add Raster layer » 

 

➢ Once a new window appears, click on   and navigate to the reference image folder of the S2 

image  (…/TP2/SENTINEL-2) 



➢ In the folder .. \SENTINEL2B_20200730-111734-503_L2A_T30UXV_C_V2-2. : 

Select the two images « SENTINEL2B_20200730-111734-503_L2A_T30UXV_C_V2-

2_FRE_B4.tif» and « SENTINEL2B_20200730-111734-503_L2A_T30UXV_C_V2-

2_FRE_B5.tif». The two images correspond to the “Red” band and the "vegetation Red edge" 

band. 

➢ When the images are added, they appear in the table of contents (TOC), and the images appear in 

the Map Display zone (zone 4). 

 

0.3. Exploration 

of metadata of 

the S2 image 

➢ In the Table of Contents, right click on the image « …….B4.tif » and select « Properties » 

➢ In the window « Properties of the layer »  click on « Information » 

 

This window gives you all the information of the image : 



o Name of the image : « SENTINEL2B_20200730-…. » 

o Path  : Path to the image 

o The projection system is found under « SCR » : 

EPSG :32630 – WGS84/UTM zone 30 N   

This means that the image is located in the zone "30N" of the UTM projection system. 

Each projection system has a unique EPSG  

o The number of lines « Width » : 10980 

o The number of columns « Height » : 10980 

o The radiometric resolution of the image « Data type » :  

Int16 - Sixteen bit signed integer 

This means that the image is saved in format 16 bits signed. The value of a pixel is between 

-32767 and 32767.  

The images S2 surface reflectance from ESA are multiplied by « 10000 » in order to be 

saved in the 16bit format. This mean that for every pixel, the value of reflectance is 

multiplied by a factor of 10 000. 

o The origin coordinates of the images are in « Origin »:  

X=600000 Y=5, 50002e6 

o The spatial resolution of the image is in « Pixel Size» :  

10 x- 10. 

➢ Repeat the process for the second image band ".....B5.tif" 

➢ Compare the two Sentinel 2 images 

0.4. Loading a 

LANDSAT 

image 

➢ Click on « Layer » ➔ « Add Layer» ➔ « Add raster layer » 

 

➢ In this window click on     and navigate to the Landsat folder (…/TP2/LANDSAT) 

➢ In this folder  …TP2\LANDSAT : 

➢ Select the image « LC08_L2SP_201026_20200602_20200824_02_T1_SR_B4.tif». This image 

corresponds to the “Red” band. 

➢ In the Table of Contents, right click on the image « …….B4.tif » and select « Properties » 

➢ In the window « Properties of the layer »  click on « Information » 



 

The LANDSAT image has a spatial resolution of 30 meters. It is encoded in UInt16 (unsigned 16 bit). 

Number of lines is7831 and the number of columns is 7731. The projection system is UTM 30 N. 

  



1. Creating a stacked image « stack » using multiple bands 

Objective: The S2 image have four bands with a resolution of 10 m, these are the blue, green, red and NIR bands. In 

this exercise, we will create an image using these 4 bands to obtain a single image with 4 layers (bands) 

Steps Manipulation 

1.1. Load the 4 

bands into QGIS 
➢ Open  QGIS 

➢ Click  « Layer» ➔ « Add Layer » ➔ « Add Raster layer» 

➢ In this window click on   and navigate to the S2 images (in TP2\SENTINEL-2) 

➢ Select the 4 bands « .tif » : "_FRE_B2", "_FRE_B3”, "_FRE_B4" and "_FRE_B8". 

➢ Click on « Add » to add them to QGIS 

➢ When you add the layers they appear in the table of contents on the left 

➢ Change the order of the four bands in the table of contents (TOC) in this order: B2, B3, B4, and 

B8. To modify the order click on the name of the layer and drag it upwards. 

1.2. Creating one 

image from 4 

bands 

➢ Open the fusion toolbox « merge », by clicking on « Raster » ➔ « miscellaneous » ➔ « merge » 

 

➢ In  «  Input layers » , click on  select the four loaded bands. Make sure they are in the 

following order B2, B3, B4 and B8. This order will be applied in the output image.  

➢ check « Place each input file into a separate band »  

➢ In « Output data type », select INT16 ( integer 16 bits). The radiometric resolution of the image 

will be an integer of 16 bits, just like the S2 bands 

➢ In « Merge », click on  ➔ save to file ➔ name the output « S2_20200730_RGBIR.tif » 

➢ Click « Run » to complete the merge  



 

1.3. Principles of 

the colors and 

composition 

The values of the pixels in each if the 4 spectral bands represent the part of the solar energy reflected 

by the terrestrial object (reflectance). In a given interval of wavelengths, the more the object reflects 

the energy, the higher the values will be (and thus they will be brighter). 

A colored composition is the optical combination (additive synthesis) of multi-banded images by 

projecting these images through a red, green and blue image. 

You can display colors in many ways, the most common are: 

o Composition naturel colors: 

• Red Filter ➔ Red Band  

• Green Filter ➔ Green Ban 

• Blue Filter ➔ Blue Band 

o Composition infrared colors: 

• Red Filter ➔ NIR Band  

• Green Filter ➔ Red Band  

• Blue Filter ➔ Green Band  

 

1.4. Displaying a 

colored 

composition 

➢ In the Table of Contents,  right click on « S2_20200731_stack.tif » and select « Proprieties » 

➢ In the Layer properties window, click on « Symbology » 



➢ Dans la zone Render type, select multiband color and now set the bands to the display colors in a 

way that results in a “natural colors” composition, as shown in the previous section. 

➢ Click on apply then on OK 

➢ Repeat this process to display the composite « infrared colors » 

In the composition « infrared colors » the vegetation appears to be red. Why is that? 

……………………………………………………………………………………….. 

……………………………………………………………………………………….. 

……………………………………………………………………………………….. 

 

2. Managing projections and clipping 

Objective: Change the projection of an image, clip an image according to the size of a vector 

Steps Manipulation 

2.1. Projecting 

an image 
As seen in exercise 0, the S2 images downloaded are in the UTM projection system. In this exercise 

we’re going to change the projection system of the image from UTM  to the national projection of 

France "RGF 93". 

➢ If the output image of the last exercise is no longer in the Table of Contents then add it again 

into QGIS (like in step 0.2) 

➢ To open the projection tool go to « Raster » ➔ « Projections » ➔ « Projection (warp) » 

 

➢ In this window: 

o Input layers : select the image S2_20200730_RGBIR.tif  

o for target SCR: click on and select  the projection RGF93/Lambert-93 

(EPSG :2154) 

o For « Projected » : click on and save it 

as « S2_20200730_RGBIR_RGF93.tif » 

o in « Nodata value output bands » specify 0 



o check « Open output file after running algorithm » 

o Click  « Run » 

o Wait… 

 

2.2. Clipping 

an image 

Our image S2 has the dimensions of 100 km x 100 km. In this exercise, we will clip the image 

according to an interest zone, using a vector shapefile. 

➢ Add the image « S2_20200730_RGBIR_RGF93.tif » to QGIS (The result of the projection 

exercise) 

➢ Go to « Layer » ➔ « Add Layer » ➔ « Add Vector layer » 

➢ Click on  and select the zone …./TP2/STUDY_SITE/zone_etude.shp 

➢ click on add 

➢ Now go to  « Raster »➔ « Extraction »➔ « Clip rater by mask layer » 

➢ In this window set the following : 

o Input layer : S2_20200730_RGBIR_RGF93.tif  

o mask layer : zone_etude.shp 

o Click on the icon   and save the output as « 

S2_20200730_RGBIR_RGF93_clip.tif » 

o Click « Run» 

 

 

 



3. Superimposing two images 
 
Objective: The objective is to resample an image that has a spatial resolution of 20 m to make it have a resolution of 

10 m. Moreover, We will change the projection system to go from  UTM to RGF93. We will do this exercise on the 

same extent that we created in the section 2.2 “ S2_20200730_RGBIR_RGF93_clip.tif” 

Steps Manipulation 

3.1. 

Superimposing 

of band B5 

As shown in  0.3, band 5 of the Sentinel-2 image has a spatial resolution of de 20 m and is in the 

UTM projection system. In this exercise, we will use a tool in OrfeoToolbox called "Superimpose" 

to resample the band B5 of the S2 image to the same spatial resolution, to give it the same projection 

and to clipped to the same extent as " S2_20200730_RGBIR_RGF93_clip.tif " : 10 m resolution 

and system with a projection RGF93 

We will first configure OTB dans in QGIS 

➢ To configure OTB : 

o Go to « Processing » ➔ « Toolbox » 

o In the toolbox window click on  

o Now click on « providers » ➔ « OTB » 

o In  «  OTB application folder » click on   ➔ « Add» ➔ Go to the directory were 

OTB was downloaded …\OTB-6.6.1-Win64\lib\otb and select the folder « applications » 

o In  «  OTB folder »  lick on  and select The OTB folder 

o check « activate » 

o lick « OK » 

 

➢ Add the band 4 from exercise 2.2 « S2_20200730_RGBIR_RGF93_clip.tif » and band 5 of the 

Sentinel-2 image from exercise 0.2. 

The image « S2_20200730_RGBIR_RGF93_clip.tif » will be used as our reference to 

resample the image B5. This means that the B5 image will have the same spatial resolution as 

the reference image (10m), the same projection system as the reference image (RGF93) and the 

same extent as the reference S2_20200730_RGBIR_RGF93_clip.tif 

➢ Now search « Superimpose »  in the tool box under OTB and double click on the tool to open 



 

➢ In the Superimpose window, set the following: 

o Reference input : S2_20200730_RGBIR_RGF93_clip.tif 

o « The image to reproject »: select the band 5 

o « Output Image » : click on      and save it as « S2_B5_20200730.tif » 

o Check  « Open output file after running algorithm » 

o Click  « Run » 

o Wait… 

 

3.2. Merging 

resampled B5 

with the image 

of 4 bands  

Since  (S2_B5_20200730.tif ) has the same resolution (10m), projection (RGF93) and extent as 

S2_20200730_RGBIR_RGF93_clip.tif,  We can now add « S2_B5_20200730.tif » as a fifth 

“band” S2_20200730_RGBIR_RGF93_clip.tif. 

Repeat the steps in exercise 1.2 (merging) and fuse the 10m (S2_B5_20200730.tif) with the image 

«  S2_20200730_RGBIR_RGF93_clip.tif ». 

In this case, resampled B5 will be the 5th band of the image. Name this image : 

S2_20200730_5band.tif 

 



4. Vegetation index 
 
Objective: Apply the arithmetic operation between spectral bands to produce the vegetation index 

  

Steps Manipulation 

4.1 Loading 

data 
➢ Open  « QGIS » and add the image S2_20200730_5band.tif. 

The image should be in  (…\TP2\output) 

o « Layer » ➔ « All layer» ➔ « Add raster layer » 

4.2 vegetation  The NDVI (Normalized Differential Vegetation index) Is a vegetation index based on the difference 

between the reflectance in red and the reflectance in NIR divided by the sum of the two reflectances : 

NDVI=
NIR−Rouge

NIR+Rouge
 

This index exploits the spectral signature of the vegetation, vegetation reflects the most in infrared, 

and much less in red. This index is useful to determine the presence of vegetation, it also may be 

used to determine the density of the biomass and thus the intensity of photosynthetic activity. 

 

Effectively; This calculation is done pixel by pixel between the two raster (spectral bands). QGIS 

contains a powerful tool called the Raster Calculator – that allows us to calculate on our existing 

data. The result will be stored as a new raster. 

 

4.3 Using the 

Raster 

Calculator 

➢ In the menu bar go to « Raster »➔ « Raster calculator » 

➢ The list « Bands raster » contains all the usable raster layers. To add a raster to the formula, 

double click its name. You can either use the operators to make the equation or you can type it 

directly in the box. 

➢ In  « Result layer» we have to define the output. The extent can be chosen from one of the raster 

layers or by giving coordinates and number of line and columns. 

➢  « Operators » has a few operators for mathematic calculation (addition, subtraction, 

multiplication, etc.) some functions (sin, cos, tan, etc.), and some logical operators (AND, OR).  

➢ In « Raster calculator expression » type the following: 

("S2_20200730_5bands@4"-"S2_20200730_5bands@3")/("S2_20200730_5bands@4" + 

"S2_20200730_5bands@3") 

➢ Remark: The syntax of the band is the following: « name of image @ ‘number’ of band » 

➢ Name the output « ndvi_20200730.tif » 

➢ Click on « Use selected layer extent » to calculate for the whole extent of the raster 

➢ Check « Add result to project » 

➢ Cliquer sur « OK »  



 

5. Zonal statistics 
Objective: The next objective is the calculate the zonal statistics from NDVI for the parcels 

 

Steps Manipulation 

5.1.  Add the 

image and the 

shapefile 

We will  now calculate the average NDVI for a few agricultural parcels and for the urban area that we 

already created in TP0. 

The result will be the average NDVI value for each polygon. 

➢ In the menu, click on « Layer » ➔ « Add layer» ➔ « Add raster Layer » 

 

Navigate to data in TP2, ..../TP2/OUTPUT and select the image "ndvi_20200730.tif " 

➢ Now go to , « Layer » ➔ « Add Layer » ➔ « Add vector layer » 



 

 

➢ Navigate to data in TP0, ..../TP0/output and select “objects.shp” 

5.2. Calculate 

statistics 
➢ Now we will calculate for each entity the average NDVI value of all the pixels that coincide inside 

it. For that we will use a tool called “zonal statistics”. 

➢ Go to Processing ➔ Toolbox : 

 

 
 

➢ Search for “Zonal statistics” and doubt click on it 

 

 
 

➢ In the zonal statistics window, set the following : 

• Input layer : ndvi_20200730 

• Raster band : Bande 1 

• Zones layer : objects 

• Output prefix: type « NDVI». This prefix will be used as a name for the new column that 

is going to be added to the attribute tableof the shapefile, it will have the average NDVI 

for each parcel. 

• In “statistics to calculate” click on  and select « mean » 

• Click on Run.  



 

➢ The column added to the attribute table of the shapefile will be called "NDVImean. It has the 

average value of NDVI for each parcel. 

➢ Open the attribute table of the shapefile to see the values. 

 



 
6. Classifying the Land Cover by a multiband threshold 
 
Objective: Use different spectral bands (or channels) to extract the Land cover of the ground surface. And combine the 

result in a file. 

 

Steps Manipulation 

6.1. 

Classification 

procedure 

The classification strategy used in this exercise is a  Top-Down approach. It works by defining a 

hierarchy of classes moving from the general to the specific, eventually creating a decision tree. 

This method allows us to set the rules of the classification on step at a time. 

For example: 

 

QGIS has recently added a semi-supervised classification tool. Previously all the treatment needed 

the Raster Calculator. 

6.2. Loading 

data  

Load the following into QGIS: 

o S2_20200730_5band.tif : S2 image that has  5 bands (green, red, blue, infrared, and 

vegetation edge red) at 10 m in resolution 

o ndvi_20200730.tif 

you can find the images in (…\TP2\output) 

6.3 Extraction 

of the water 

class 

NIR is especially important for water detection. In fact, water absorbs most of the radiation in this 

band and so the possibility of confusing it with other things on the surface is very low. At threshold 

of infrared of 600 will be used. All the pixel with values below 600 will be considered as water. 

Since the S2 values are multiplied by 10000 the actual reflectance is « 600/10000=0.06 ». 

➢ Go the  Raster »➔ « Raster calculator » 

➢ Add the following expression : 

"S2_20200730_5bands@4" < 600 

This way all the values with value below 600 will be given a 1 and the others will be given a 0. 

➢ Save as "water.tif". 

➢ click « add projected result» 

6.4. Extraction 

of the land 

class 

It will be the opposite of the water class.  

 

➢ Type the following in the raster calculator : 

" S2_20200730_5bands@4" >= 600 

Enow all the values equal to or below 600 will get the value of 1, and everything else will get a 0. 

➢ Save under "land.tif". 

➢ check « Add projected result » 

Water ground 

Weak 

vegetation 

Urban Dense 

vegetation 



6.5. Extraction 

of the urban 

class 

We will determine the urban class using NDVI band and NIR (band 4 in our image). 

 

➢ Type the following into the raster calculator : 

 "land@1" = 1 AND "S2_20200730_5bands@4"<2100 AND "ndvi_20200730@1"<0.5 

Using this expression, all the pixels with a value of 1 in image class “land” (1 for land and 0 for 

everything else) and a value below  2100 for the NIR band and an NDVI below 0.5 get the value of 

1,everything else gets a 0. 

➢ Save as "urban.tif". 

➢ check « Add projected result » 

6.6. Extraction 

of low 

vegetation 

The low vegetation class is defined  as a surface that is not water, not urban with  moderate values 

of NDVI. 

 

➢ Type the following in the raster calculator : 

  "land@1" = 1 AND "urban@1" = 0 AND "ndvi_20200730@1"<0.6 

The pixels with a value of 1 in the image de of land class and a value of 0 in the urban class image 

a value of NDVI below 0.6will get a value of 1, everything else will get a 0. 

➢ Save as "low_vegetation.tif". 

➢ check « Add the projected result » 

6.7. Extraction 

of the dense  

vegetation 

The low vegetation class is defined as a surface that is not water, not urban with high values of 

NDVI. 

 

➢ Type the following in the raster calculator : 

  "land@1" = 1 AND "urban@1" = 0 AND "ndvi_20200730@1">=0.6 

All the pixel with value 1 for land, 0 for urban and NDVI higher than 0.6 will get the value of 1, the 

rest get a 0. 

➢ Save as "dense_vegantation.tif". 

➢ check « Add the projected result » 

6.8. 

Combining 

classes in one 

raster 

Merging the fou4 classes: 

All our input image are binary (0,1) the value of 1 represents the classe To merge the 4 images in a 

classification, we will represent each class by a number from 1 to 4. 

• water (1) 

• urban (2) 

• low Vegetation (3) 

• dense Vegetation (4) 

This is done in the raster calculator 

 

➢ Type the following : 

"water@1"+"urban@1"*2+"low_vegetation@1"*3+"dense_vegetation@1"*4   

➢ Save as nom "classification.tif". 

➢ check « Add the projected result » 



6.9. Display 

the labels by 

color 

The classification image contains 4 distinct classes (1, 2, 3 and 4). We will give a representative 

value for each class. 

➢ Right click on the image  « classification.tif » and select « Proprieties »  

➢ In  « Proprieties » go to « Symbology » 

➢ in « Render type » select « Paletted/Unique Values» 

➢ click on  « Classify » 

➢ For each class double click on the “label” value and change the names accordingly 

➢ Choose blue for class 1 , brown for class 2, green for class 3 and dark green for class 4 

➢ Change the labels (water, urban, low vegetation, dense vegeatation) 

  

 

6.10. Post-

classification 

filtering 

The result has some isolated pixels, giving a grainy image. It isn’t necessary but it it better to correct 

this anomalies to respect the principal of minimal cartographic unit (UMC) on one hand, and to 

reduce the number of vectors that we will obtain when vectorizing. 

➢ Go to  Raster ➔ Analysis➔Sieve 

In the sieve window 

o Input layer : classification.tif 



o Threshold = 10 

o Save as Postclassifcation.tif 

o click sur Run 

When done, right click on  "classification.tif"➔styles ➔ copy style 

Then right click on "PostClassification.tif"➔style➔ Paste style 

 

                             Classification                                                      PostClassification 

 

 


